« [Ruby] 限界 | トップページ | [Ruby] heckle その2 »

2009年6月25日 (木)

[Ruby] heckle

1.4.3が公開された([ruby-talk:339964])。

ユニットテストを支援するためのツール。 コードを変更してすべてのテストが失敗することを確認するためのツールということであってますか?

Ruby 1.9dev で試してみたけどエラーになった。

$ heckle -v
heckle-1.4.3/lib/test_unit_heckler.rb:3:in `require': \
no such file to load -- test/unit/autorunner (LoadError)

test/unit/autorunner.rb は、test/unit が minitest ベースに移行した関係で 1.9.2dev にはない。

|

« [Ruby] 限界 | トップページ | [Ruby] heckle その2 »

コメント

この記事へのコメントは終了しました。

トラックバック


この記事へのトラックバック一覧です: [Ruby] heckle:

« [Ruby] 限界 | トップページ | [Ruby] heckle その2 »