« [Ruby] UPnP | トップページ | [Ruby] hoe »

2009年6月17日 (水)

[Ruby] soleb と Ruby 1.9.X

soleb 0.0.1a が 1.9.1 でも 1.9.2dev でも一応動いた。 確認した環境は、

ruby 1.9.1p154 (2009-05-22 revision 23541) [i386-cygwin] 
ruby 1.9.2dev (2009-06-17 trunk 23725) [i386-cygwin] 

の2つ。

なお、1.9.1 だと、

 Sun May 17 09:31:05 2009  Masaki Suketa
 
         * ext/win32ole/win32ole.c (foletypelib_name): should return
           encoded name corresponding to WIN32OLE.codepage.      

が適用されてないと文字化けします(ChangeLogから抜粋)。 実際のところは、soleb.rb を実行してみたら文字化けしたので、調べて上のコミットをしました。

また、soleb の実行には、swin と vruby が必要です。 swin は、09/02/07、vruby は、08/02/09 を使用して確認しています。 swin と vruby は、nyasu さんが開発されており、 VisualuRuby計画のダウンロードのページからダウンロードできます。

|

« [Ruby] UPnP | トップページ | [Ruby] hoe »

コメント

この記事へのコメントは終了しました。

トラックバック


この記事へのトラックバック一覧です: [Ruby] soleb と Ruby 1.9.X:

« [Ruby] UPnP | トップページ | [Ruby] hoe »